System Mechanic Start-up Error?

When I start up System Mechanic I get the following error “list index out of bounds ()”. Afterwards the program continues to load indefinitely but never starts up. This problem does not occur with iolo Firewall or Virus Protection. Also I just started to the get same error on my dads computer at the same time I get mine.

✅ Answers

? Favorite Answer

  • I had the same problem and I have just received a response from http://www.iolo.com/customercare.

    “Should this issue persist, Exit System Mechanic.

    On Windows XP, delete the C:Documents and SettingsAll UsersApplication DataioloStatus.xml file.

    On Vista or Windows, navigate to the C:ProgramDataiolo folder and delete the files named smgthints.xml and status.xml. Its easier to access from the Start button. Click on Start and in the Search box type C:ProgramData and click Enter, the folder should open. Then double-click on the iolo folder and delete the files.

    Start System Mechanic and let us know if that works.

    Thank you for your time and patience. If you have any further questions, suggestions, or comments about any of our products, don’t hesitate to contact us using this case. To provide for better tracking of your issue and to ensure accurate responses by Customer Care, please do not start a second case on the same issue as this may cause unnecessary delays. You may also visit Customer Care online at http://www.iolo.com/customercare.%

    Problem solved

  • I’m having the exact same problem…I thought it was an error in the registry and I tried to fix it,but I just made it worse.I had to do a system restore from the windows install disc to get my computer to work again.I emailed iolo support….but still no answer yet.

    See also  VMware Fusion , windows /Mac side by side.?

    If your thinking of tweaking the registry….I would not recommend it !!

    I found many other System Mechanic users who are having the same problem.

    In the meantime,I would contact iolo and report your problem.

    They most likely will have a fix for this in a few days.

    Source(s): Here is a link to the customer care:
    http://www.iolo.com/customercare/technicalsupport….
    I wouldn’t bother with any attempts to repair it yourself, it would be better to wait until you hear from iolo support.

  • For some reason there was an issue with a file update that provides certain tools in System Mechanic with file information, such as startup items and running processes, either did not download correctly or did not register correctly. The steps below will resolve the issue and we will be implementing an internal process within System Mechanic so that this will not occur again.

    . From the Windows Desktop, please perform a CNTRL+ALT+DEL with the keyboard and select the Windows Task Manager.

    . Go to the Processes tab, highlight the process named “ioloServiceManager.exe” and select End Task. If using Windows , you will need to select the button to view processes of all users.

    . Please delete the file named ioloFileInfoList.dll from your system.

    Windows XP

    C:Program FilesioloCommonLib

    Windows Vista and Windows

    -bit systems: C:Program FilesioloCommonLib

    -bit systems: C:Program Files (x)ioloCommonLib

    . Close all open windows and start System Mechanic. There will be a notification for a Tune-Up Definitions update, please follow through with the update by selecting the Download and Install Now button.

    . After the update is finished, please close System Mechanic.

    See also  I have a RAR file and have downloaded winRAR to try and open it but still struggling?

    . Please click on the Windows Start button and select Programs (or All Programs), Accessories and then Command Prompt. Please type in the following at the command line including the quotes (for your given platform):

    -bit systems: “C:Program FilesioloCommonLibioloFILParser.exe” /autoshutdown /uselocal

    -bit systems: “C:Program FilesioloCommonLibioloFILParser.exe” /autoshutdown /uselocal

    . Restart your computer.

    Thank you for your time and patience. If you have any further questions, suggestions, or comments about any of our products, don’t hesitate to contact us using this case. To provide for better tracking of your issue and to ensure accurate responses by Customer Care, please do not start a second case on the same issue as this may cause unnecessary delays.

    Source(s): This was a response I received today from IOLO Customer Care at http://www.iolo.com/customercare

  • Iolo Customer Care

    Source(s): https://shorte.im/aN

  • . Maybe some maintenmace on both machines

    Clear Cache – go to Toolbar above

    TOOLS>INTERNET OPTIONS> delete Browsing History -the click APPLY> OK

    Run antispyware like CCleaner and Spybot

    CCleaner – run the CLEANER and REGISTRY

    . If that’s not a fix – try uninstalling the program throur ADD/ REMOVE in the Control Panel – do a clean install

    POWER DOWN your machine after each setp to be sure it took effect

    Source(s): http://www.ccleaner.com/
    http://www.safer-networking.org/en/index.html latest version ..

  • I to had this porblem and I had to download and reinstall system mechanic, I even went into the

    registry and deleted the iolo software entry, I am running windows vista ultimate, maybe iolo will

    send a fix to this problems

  • It’s possible definitely

  • I would like to know more about this as well

    See also  what is the best site to download free mp music without viruses? (Kazza, etc)?
  • Leave a Comment